Package php-mysql is obsoleted by php-mysqlnd

Wondering how to resolve Package php-mysql is obsoleted by php-mysqlnd? We can help you.

At Bobcares, we offer solutions for every query, big and small, as a part of our Server Management Service.

Let’s take a look at how our Support Team help a customer  deal with this Plesk error.

How to resolve Package php-mysql is obsoleted by php-mysqlnd?

Plesk for Windows supports Microsoft SQL and MySQL.

The Plesk Platform includes extensions for Backup, DNS, Cloud, Security, and Server Tools.

And its control panel allows its users to set up new websites, reseller accounts, email accounts, edit and create DNS entries, and many more, through a web-base interface.

PHP is a server-side scripting language, hence it creates significant dynamic pages with customize features.

One of the main benefits of using PHP and MySQL is, it provides an interactive, user-friendly website.

And also facilitates visitors to openly interact while producing a genuinely dynamic and flexible content.

Typically, plesk cannot update with the following error:

php-mbstring.x86_64 0:Package php-mysql-5.4.45-14.el7.remi.x86_64 is obsoleted by php-mysqlnd-5.6.33-1.el7.remi.x86_64 which is already installed
Exception: Failed to solve dependencies:
psa-php5-configurator-1.7.0-cos7.build1705170314.17.x86_64 requires php-mysql

Today, let us see the steps followed by our Support Techs to resolve it.

  1. Log in to the server via SSH

    Note: if direct SSH access to the server is not possible, contact server administrator for further assistance.

  2. Install rpm-build package using the following command:

    yum install rpm-build

  3. Create a file php-mysql.spec:

    touch php-mysql.spec

  4. Edit php-mysql.spec file and paste the following content in it:

    Summary: The empty php-mysql package
    Name: php-mysql
    Version: 8.0.0
    Release: 1
    License: Public
    Group: Applications/System
    %description
    The empty php-mysql package
    %files

  5. Build the package with the following command:

    rpmbuild -bb php-mysql.spec

  6. Install the created package with the following command:

    rpm -Uvh /root/rpmbuild/RPMS/x86_64/php-mysql-8.0.0-1.x86_64.rpm

  7. Run Plesk upgrade one more time.

[Need a solution to another query? We are just a click away.]

 

Conclusion

Today, we saw steps followed by our Support Engineers to resolve Package php-mysql is obsoleted by php-mysqlnd.

PREVENT YOUR SERVER FROM CRASHING!

Never again lose customers to poor server speed! Let us help you.

Our server experts will monitor & maintain your server 24/7 so that it remains lightning fast and secure.

GET STARTED